Meraki Switch stacks creating duplicate devices in the product

Incident Report for Auvik Networks Inc.

Postmortem

Service Degraded - Duplicated Devices for Meraki Switch Stacks

Root Cause Analysis

Duration of the incident

Discovered: Dec 15, 2025 08:34 – UTC
Resolved: Dec 15, 2025 13:20 – UTC

Customer impact

Customers with Meraki switch stacks across all clusters experienced:
Duplicate Meraki switches are appearing in the device inventory, including entries without management IP addresses.
Inability to manually delete duplicates, as they were automatically recreated.
Confusing or inaccurate device and stack representations.
Temporary inflation of billable device counts for some tenants (billing data captured and under review).
No other device types were affected.

Cause

A configuration update intended to improve how Meraki switch stacks are represented in the platform caused unintended behavior.
For tenants already using Meraki stacking, the system was unable to match newly processed stack data to existing switches consistently. This caused already-stacked switches to be incorrectly interpreted as new devices, generating duplicate inventory entries. Because the underlying synchronization logic reinforced these entries, any customer deletion of duplicates did not persist, and duplicates reappeared.

Effect

The issue led to inaccurate device inventories and misleading switch-stack views for customers using Meraki stacking, causing confusion in device management and increasing support tickets. Internal teams experienced additional operational overhead as they investigated the duplication patterns and validated safe removal procedures. Complete remediation required coordinated cleanup across all clusters to restore accurate device records and ensure no further duplicates were generated.

Future consideration(s)

  • Strengthen validation of device and stack metadata before inventory updates.
  • Improve testing coverage using a production-like stacked device configuration.
  • Add monitoring and alerting for abnormal changes in device counts.
  • Use safer rollout controls and feature flags for changes affecting device inventory logic.
Posted Dec 19, 2025 - 11:28 EST

Resolved

The incident has been fully resolved, and all services are operating normally.

Customers should no longer experience any related issues. If you continue to experience problems, please don't hesitate to contact Auvik Support.

We will provide a Root Cause Analysis (RCA) once it is available.
Posted Dec 15, 2025 - 13:23 EST

Monitoring

We have applied changes to address the issue. You'll now see the duplicate begin to be removed.

Impact:
Services should be operating normally; however, if you continue to encounter problems, please report them to Auvik Support.

Next Steps:
A final update will be posted once we confirm the resolution.
Posted Dec 15, 2025 - 12:35 EST

Identified

Our team has identified a suspected cause of the Meraki duplicate Stack switches and is taking steps to remediate the issue.

Impact:
Customers may continue to experience duplicated Meraki Stack switches
The following services are not affected: Alerting and all other Device inventory.
Please report any related issues to Auvik Support so we can track and assist further.

Next Steps:
We are applying mitigation measures and will provide updates on progress.
Posted Dec 15, 2025 - 11:52 EST

Update

We are currently investigating reports of Meraki switch stacks creating duplicates.

Impact:
Customers may see duplicate inventory in the Meraki stacks.
No new devices are currently being created. Devices that have been duplicated cannot yet be deleted.
The following services are not affected: Alerting and all other Device inventory.

Next Steps:
Our team is working to identify contributing factors. Updates will follow as more information becomes available.
Posted Dec 15, 2025 - 10:02 EST

Investigating

We are currently investigating reports of Meraki switch stacks creating duplicates.

Impact:
Customers may see duplicate inventory in the Meraki stacks.
The following services are not affected: Alerting and all other Device inventory.

Next Steps:
Our team is working to identify contributing factors. Updates will follow as more information becomes available.
Posted Dec 15, 2025 - 09:35 EST
This incident affected: Network Mgmt (us1.my.auvik.com, us2.my.auvik.com, us3.my.auvik.com, us4.my.auvik.com, us5.my.auvik.com, us6.my.auvik.com, eu1.my.auvik.com, eu2.my.auvik.com, au1.my.auvik.com, ca1.my.auvik.com).